1. General information


1.1. About the system

1.1.1. StoreHouse4 is an accounting system for restaurant stocks.
1.1.2. The system is a windows OS application (Windows 2000, Windows XP, Windows 2003 Server, Windows 7, Windows 2008 R2 Server).
1.1.3. The system uses its own database format and is database management system itself.


2. Server


2.1. Installation

2.1.1. Blank installation

Распаковать (если дистрибутив в архиве) файл shsrv_4XXXX.zip и запустить файл setup.exe (XXXX-версия текущего дистрибутива, например shsrv_44577.zip). На первом окне инсталляционного пакета будет указан номер устанавливаемой версии (в виде 4.XX.XX). Указать директорию, куда будет установлена серверная часть (по умолчанию C:\UCS) Указать директорию, где будет в дальнейшем создана база данных (при инсталляции пустая база данных не создается)-по умолчанию C:\UCS\SDBSrv\Database Дождаться окончания копирования файлов. Запустить основную конфигурационную утилиту для серверной части SdbsConf.exe (по умолчанию находится в директории C:\UCS\SDBCli

2.1.2. Using translation files

2.1.2.1. Run setup from server’s installation.
2.1.2.2. When installation wizard will ask where to install, set path where you copied language files (for example d:\ucs).

2.1.2.3. After installation wizard is finished, select “Launch the program” and press “Finish”.
2.1.2.4. In opened window “Server setup utility” set following settings:

2.2. Configuring

2.2.1. SdbsConf.exe utility

2.2.1.1. Server name – network name of server, name should be unique on the network. Also set description of server (optionally, without that it will not show server name in “Login window”).
2.2.1.2. Database file – empty (because installation doesn’t create database, it should be done separately as in 4.)
2.2.1.3. Database log – empty
2.2.1.4. Library directory – leave as it is (path where dll’s (ShServ.dll, sh_crtdb.dll, ShTrans.dll) are located)
2.2.1.5. Backup directory – path to folder there backups will be created.

2.2.1.6. Backup options – settings how and when backups of DB should be created.

2.2.1.6.1. There is possibility to set exact backup time (Backup time), or to make backups on starting (On database loading) or shut downing of SH4 server (On server shut down). Option Stop server on error means if on backup procedure will appear error, server will stop.

2.2.1.6.2. We recommend you set additional "hot" backup using external applications like windows system backup and recovery.

2.2.1.7. Net protocols – which protocols will be supported by server. For all protocols there is possibility to set timeout. For Netbios protocol adapter number is required (if you set this wrong - server won't start), and for Tcp/ip – port.
2.2.1.8. Cache (pages) – leave empty. If database is very big and Windows is saying that not enough cache, then it is recommending to set cash size bigger than database. Remember 1 page is equal 4 Kb,
Working set size (bytes) – leave empty.
Priority class – what priority will have program in operating system
Startup mode – how server will be started (manual – user will have to run server, windows – windows will automatically start server as application on startup, service – server will be started as service (possible only on Windows NT))
Automatic recovery – if error occurred on some transaction
REMARK: if several databases are necessary to run, you have to configurate several servers. One server for one database. 
 

Server name (Имя сервера) - задает уникальное имя сервера. Описание сервера можно использовать для служебных или информационных целей. Можно создать столько серверов, сколько необходимо для работы. Следует помнить, что каждый сервер может обслуживать только одну базу данных!. По умолчанию имеет значение SDBSERV без описания (Description)

Database file (Файл базы данных) - указывает полный путь к базе данных сервера. База данных не уставливается при инсталляции, а создается отдельно с помощью клиентского приложения Sdbman - см. раздел ниже. Прописывать после создания баз, иначе сервер не запустится! Database log (Журнал транзакций) - указывает полный путь к журналу транзакций сервера. Журнал транзакций также не устанавливается при инсталляции, а создается одновременно с базой данных. Прописывать после создания баз, иначе сервер не запустится!  

  • Library directory (Директория с библиотеками) - указывает на директорию, в которой находятся служебные библиотеки сервера. По умолчанию ссылается на путь, который указан при инсталляции сервера. Значение этого параметра не следует изменять без необходимости!
  • Backup directory (Архивная директория) - указывает директорию для хранения (автоматического и ручного) архивов базы данных. По умолчанию указывает на поддиректорию Bak основной директории сервера.
  • Backup options (Настройки архивации) - устанавливает различные настройки архивации базы данных (Automatic backup disabled). Крайне рекомендуется настроить автоматическую архивацию данных: (Enable automatic backup). Можно указать период архивации  (Period, days) и выбрать один из трех вариантов времени архивации:
    • указать конкретное время (Backup time)
    • производить архивацию при загрузке сервера (On database loading)
    • производить архивацию при остановке сервера (On sever shutdown).

    Также можно указать опцию остановки сервера при неудачном завершении архивации –Stop server on error. При включении этой опции, после неудачной попытки архивирования, сервер будет остановлен, и клиенты получат сообщении о невозможности продолжать работу.Все параметры автоматического архивирования необходимо согласовать с ИТ-отделом заказчика или пользователя системы!

  • Net protocols (Сетевые протоколы) - указывает сетевые протоколы, которые будет поддерживать сервер для входящих соединений - по умолчанию установлена поддержка только одного протокола - локального (Local), т.е. для подключения клиента только на том же компьютере, где установлен сервер. Возможно установить поддержку подключения по протоколу TCP/IP (работает только с версии StoreHouse 4.10) и через интерфейс NetBIOS (может использоваться как протокол NetBEUI, так и TCP/IP). По умолчанию параметры Timeout (ms) и Port/adapter не заполнены, т.е. сервер будет использовать значение Timeout по умолчанию (2000 ms) и прослушивать все доступные порты и адаптеры. При необходимости эти параметры можно изменить (например, использовать только определенный порт TCP/IP в случае работы через firewall)
  • Cache pages (Страничный кеш)) и Working set size (bytes) (Размер рабочего набора в байтах)  относятся к операциям с памятью, и по умолчанию пустые - эти параметры следует изменять только при некорректной работе сервера или других неполадках (значения, определяемые сервером по умолчанию, можно посмотреть в протоколе сервера - в файле sdb.txt –см. описание параметра Server log). Вот пример фрагмента протокола:
20.05.2005 20:40:15- Server started
version=1.15
subkey=SDBSERV
def working set size min=204800, max=1413120
max cache memory=1024 pages (4096 K)

  • Priority class (Приоритет для процесса) -  указывает, с каким приоритетом будет запускаться сервис (в том случае, если Режим запуска (Startup mode) установлен как Сервис (Service)-см. ниже). Возможны три варианта – Низкий (Idle), Средний (Normal), Высокий (High)
  • Startup mode (Режим запуска) определяет, как будет запускаться сервер. Возможно три режима: Ручной запуск (Manual), Автозагрузка с OC (Windows), запуск приложения как сервис (Service). Рекомендуется устанавливать последний режим запуска (Service), если OC из семейства Windows NT

Чтобы корректно к серверу-сервису подключались приложения-клиенты, нужно использовать TCP/IP протокол; для этого в данном конфигураторе прописать порт, а в конфигураторе SHSetup.exe указать сервер: IP адрес (если клиент на локальной машине сервера – 127.0.0.1) и тот же самый порт!

  • Automatic recovery (Автоматическое восстановление) определяет, будет ли сервер восстанавливать при сбоях базу данных. Восстановление происходит при запуске сервера и использует для восстановления информацию из Журнала транзакций (Database Log). Рекомендуется всегда использовать этот параметр.
  • Open read only (Открывать только для чтения) позволяет открывать базу данных только для чтения.
  • Server log (Протокол работы сервера) определяет файл, в который будет записываться служебная информация о работе сервера.
  • На закладке Настройки (Settings) указывается путь к корневой директории сервера. Эта настройка необходима серверу для доступа к служебным утилитам и библиотекам. При указании неправильной директории, при сохранении настроек пользователь получит сообщении об ошибке.

После изменения настроек их необходимо сохранить, нажав кнопку Сохранить (Save) 

Далее необходимо установить драйвер электронного ключа защиты, который по умолчанию находится в директории C:\UCS\Novex, запуском приложения INSTDRV.EXE (если используются электронные ключи Novex Stealth II, необходимо использовать версию драйвера не ниже, чем 4.85).

Примечание:  Ключ и драйвер устанавливается только на компьютер, на котором запускается сервер!

Если ключ не установлен или не корректно прописан (см. ниже) клиент при подключении получит сообщение «Ошибка чтения ключа защиты». Возможна ситуация, при которой сработает ограничение ключа по дате или по числу возможных подключений (определяется приобретенной лицензией) - в таком случае клиент получит сообщение «Превышено допустимое количество соединений»

По окончанию нужно сохранить все настройки в конфигураторе сервера и перезагрузить компьютер. Убедиться, что сервер запущен - в случае запуска как Сервис, проверить через «Пуск»-«Настройка»-«Панель управления»-«Администрирование»-«Службы», что соответствующий сервис (Sdb server : <имя сервера>) находится в состоянии «Работает» и тип запуска «Авто»

В случае Автоматического запуска (Windows) или Ручного (Manual) должна появиться иконка сервера в правом нижнем углу рабочего стола Windows (возле системных часов)

Примечание: Если вы создали несколько серверов и используете Ручной режим запуска (Manual), сервер необходимо запускать с ключем /n<ИмяСервера>, т.е. если есть два сервера с именами SDB01SERV и SDB02SERV, вы должны выполнить следующие команды:
 

Sdbserv.exe /nSDB01SERV
Sdbserv.exe /nSDB02SERV

В случае Автоматического запуска (Windows) или запуска как Сервис (Service), конфигуратор сам создаст необходимые настройки

При первом запуске приложения StoreHouse v4 необходимо прописать электронный ключ защиты (пользуются стандартные ключи Novex Stealth или Novex Stealth II) с помощью приложения SHKey.exe (по умолчанию находится в директории C:\UCS\SDBCli). Для этого запустите приложение и нажмите кнопку «Получить вопрос» - полученный код необходимо сообщить компании UCS (отправить по электронной почте по адресу sh4@ucs.ru, обязательно указав название вашей организации). После получения ответного кода активации, его необходимо вставить в нижнее поле и нажать кнопку «Сохранить ответ». В случае успешного активирования кода вы получите соответствующее сообщение. При прописывании ключа должен быть подключен только один складской ключ - при наличии других электронных ключей, их необходимо отсоединить.

ВАЖНО:  После 7 (семи) неудачных попыток записать лиценцию, ключ будет заблокирован!  

 


3. Client


3.1. Installation

I. Client installation
a) If Client will be installed on different machine than server – copy language support files as it is described in I. a)
b) Run setup from client’s installation folder (usually it is sh4xxxx_cli).
c) When installation wizard will ask where to install, set path where you copied language files (for example d:\ucs)
d) After installation wizard is finished, select “Launch the program” and press “Finish”
In Storehouse setup utility set parameters for client:
Server - server name if client will connect over Local or Netbios protocol, and IP address of server if client will be connected over TCP/IP protocol
Protocol – which protocol will be used to connect to server
Port/adapter – if TCP/IP protocol is used, set port number (see port settings for server), if Netbios – adapter number. If Local protocol is used leave this field empty
Timeout – set timeout if necessary, usually it is needed if client connects to server through Internet
Store X last user names – how many login names will be stored in Login window.
Allow server name input – allows in Login window input server’s name
Allow report designer – allows in module SH4 edit print forms.
Recommended cache size in pages -
Administrator library – path for SHadm.bpl file
Press “Save”.
c) After installation of client is completed, copy other Your language files to installed program location (frprn.bpl, sh.rpt, RPT folder). These file for English version are located in Lang_sup folder
 

Для установки клиентской части можно использовать любую современную версию OC Windows, (не ниже Windows 98).
Для установки и конфигурирования клиентской части необходимо

  1.   Распаковать (если дистрибутив в архиве) архив sh4cli_4XXXX и запустить файл setup.exe (XXXX-версия текущего дистрибутива).
  2.   Указать путь, куда будет установлена клиентская часть (по умолчанию C:\UCS\SH4)
  3.   Дождаться окончания копирования файлов.
  4.   Запустить утилиту конфигурирования клиентской части SHSetup.exe (по умолчанию находится в директории C:\UCS\SH4).

3.2. Configuring

  • В окне "Сервер" указывается имя сервера, к которому будет подключаться клиент. Если в качестве протокола обмена выбран TCP/IP (см. ниже), то вместо имени сервера должен быть указан IP адрес компьютера, на котором запущен сервер. В качестве Псевдонима можно указать описание базы данных (т.к. сервер может работать только с одной базой данных, то Псевдоним будет определять не только сам сервер, но и базу, с которой он работает, например «База предприятия №1» или «База предприятия №2»).Если это поле заполнено, то при входе в приложение пользователю будет предложен список псевдонимов, иначе пользователю будет предложен список серверов (см .ниже). С помощью списка серверов можно ограничить доступ клиента к различным базам (серверам), т.е. клиент сможет получить доступ только к тем базам (серверам), которые определены в SHSetup.exe, независимо от кол-ва баз (серверов), определенных на сервере.
  • В "Параметрах подключения" указывается протокол, по которому клиент будет подключаться к серверу. Возможны несколько вариантов:
    • локальное подключение (Local)
    • подключение по протоколу TCP/IP (TCP/IP)
    • подключение через интерфейс NetBIOS (NetBIOS).

    Дополнительно можно указать порт (Порт) и адаптер (Адаптер), а также Таймаут в мс. Номер порта определяется настройками сервера (см. раздел Установка серверной части) - на сервере и клиенте должны быть указаны одинаковые (свободные) номера портов. В качестве номера адаптера должен быть указан текущий номер адаптера NetBIOS –при этом на сервере это значение может быть не указано - сервер «слушает» подключение по всем номерам адаптеров

  • С помощью операции «Добавить сервер» / «Удалить сервер» можно добавить и удалить строку, для добавления дополнительных серверов. Эта операция также доступна по правому нажатию кнопки мыши в верхнем окне.
  • Параметр «Хранить …. последних имен пользователей» определяет, сколько имен пользователей будет храниться при входе в клиентское приложение. При превышении этого значения, новым пользователям для входа необходимо будет вводить свое имя вручную.
  • «Разрешить ввод имени сервера» позволяет пользователям при входе указывать произвольное имя для подключения (либо имя сервера, либо имя псевдонима). Рекомендуется этот параметр оставлять выключенным и определять для всех серверов информативный псевдоним.
  • «Разрешить дизайнер отчетов» позволяет вызвать режим редактирование макета отчета. Рекомендуется включать этот режим только для опытных пользователей.
  • «Рекомендованный размер кеша в страницах» позволяет определить произвольное значение кеша. Рекомендуется значение этого параметра оставлять по умолчанию (пустое)
  • «Библиотека администратора» указывает путь к административной библиотеке (по умолчанию C:\UCS\SH4\SHAdm.bpl).

  После настройки всех параметров их необходимо сохранить, нажав кнопку «Сохранить»


4. Database


4.1. Creating new database

4.1.1. Copy from language pack for current version file SH_CRTDB.ini to server’s folder (replace default russian one).

4.1.1.1. You have to translate this file into your language before database creation.

4.1.2. Run program SDBMAN.EXE. It is located in D:\UCS\SH4. On Login window Copy connection string ("DataBase") and press “Cancel”.
4.1.3. In opened window select Other->Create database.

4.1.3.1. Server – connection string (Database can be created only on computer – server and client should be installed on one machine). Input the connection string copied (in case of TCP/IP it is the following format: 127.0.0.1:pTa951t50000 ; in case of local protocol it is name of the server ).
4.1.3.2. Data file – database
Initial size of the data file in pages, in MB – size of database which will be created. This size means what will be size of database all time (as data is entered into database, size is not changing). After limit will be reached – backup/restore will necessary.
File of register of updating – Database log
Initial size of the register file in pages, in MB – the same like database size
Path to libraries – path where sh_crtdb.dll file is located.
Path for archive – path where backups are created
Name of database administrator – user name which will be as administrator for this database
Administrator password – password for created user
Confirm password.
4.1.4. Press “OK”.

4.2. Procedures

4.2.1. Restart program SDBMAN.EXE after database is created. Go to "File" -> "Connect to server".
4.2.2. In Login window enter user name and password which were created with database (by default "Admin" and blank password). Ignore error messages (“Procedure "ShCommonInfo" is not found in the library” and Error loading library). Just press OK.
4.2.3. Go to "Other" -> "Execute query".
4.2.4. Input procedure "BuildAll", select library "sh_crtdb.dll" (default pathway is С:\UCS\sh4\srv\SH_CRTDB.DLL). Press "Document" -> "Perform".
4.2.5. Also execute procedure "Populate" (the same library).
4.2.6. Run StoreHouse and check that program is running correctly.

Для создания рабочей базы данных (как отмечалось выше, пустой базы нет в дистрибутиве), необходимо воспользоваться приложением Sdbman.exe (по умолчанию находится в директории C:\UCS\SH4). Базу данных необходимо создавать на сервере! Для этого может понадобиться установка клиентского приложения на сервер. Рекомендуется использовать локальное подключение при создании базы данных. Если вы впервые создаете базу данных, то переходите к пункту 3, если хотите создать пустую базу для сервера, который уже работает с данными, предварительно выполните следующие действия:

  • остановите сервер баз данных
  • перенесите в любое место старые базы данных
  • запустите приложение SDBConf.exe (по умолчанию находится в директории C:\UCS\SDBCli). Запомните значение параметров Database file, Database logs, а затем очистите их!
  • запустите сервер баз данных и переходите к пункту 3
  1. Запустите приложение Sdbman.exe (по умолчанию находится в директории C:\UCS\SH4) - на предложение ввести имя и пароль, нажмите «Отмена»
  2. Выберите пункт меню «Прочее» - «Создать базу данных…»
  3. В окне «Создание базы данных» необходимо заполнить следующие поля:
  • Сервер: - указать имя сервера, к которому будет подключаться приложение при создании базы данных. Как было указано выше, рекомендуется использовать локальное (Local) подключение при создании базы данных. Если же вы, по каким-либо причинам, хотите использовать подключение по протоколу TCP/IPi, то в качестве имени сервера необходимо указать строку вида 127.0.0.1:pTa3333, где 127.0.0.1-IP адрес компьютера, на котором запущен сервер баз данных, а 3333-порт для подключения (указан для примера). Если сервер «слушает» все порты, можно указать строку вида 127.0.0.1:pT, т.е. без указания порта.

Имя сервера здесь указывается именно так, как в первой строке SdbsConf.exe.

  • Файл данных: - указать полный путь, по которому будет создан файл базы данных. Имя базы данных может быть произвольным, но расширение рекомендуется создавать стандартное *.sdb
  • «Начальный размер файла данных в страницах … МБ … » - можно указать размер создаваемой базы данных в страницах, либо в мегабайтах - эти два параметры взаимосвязаны, т.е. изменение одного влечет за собой изменение другого. При создании новой базы данных, эти значения можно оставить по умолчанию (35000 в страницах или 136,719 в Мегабайтах) – в дальнейшем размер базы данных можно изменить с помощью приложения Sdbman.exe. Если вы создаете базу данных для переноса информации из 3-й версии склада, то необходимо указать размер, НЕ МЕНЬШИЙ, чем текущий размер базы данных 3-го склада.
  • «Файл журнала обновлений» - указать полный путь, по которому будет создан файл журнала транзакций. Имя файла журнала транзакций может быть произвольным, но расширение рекомендуется создавать стандартное *.sdl.
  • «Начальный размер файла журнала в страницах … в МБ: …» - можно указать размер создаваемого файла транзакций либо в страницах, либо в мегабайтах - эти два параметры взаимосвязаны, т.е. изменение одного влечет за собой изменение другого. При создании файла транзакций эти параметры можно оставить по умолчанию (1024 в страницах или 4 в Мегабайтах), т.к. размер этого файла можно изменить в процессе работы с помощью приложения Sdbman.exe
  • «Путь к библиотекам» - определяет путь к системным библиотекам сервера. По умолчанию это директория C:\UCS\SDBSrv.
  • «Путь к архиву: » - определить директорию, в которой будет создаваться архивная копия базы данных (при ручном или автоматическом архивировании)
  • «Имя администратора базы данных: » - указать имя администратора базы данных. По умолчанию имя пользователя Admin
  • «Пароль администратора: », «Подтверждение пароля:»-указать пароль и подтверждение пароля администратора, имя которого введено в предыдущем поле. По умолчание пароль пустой (для пользователя Admin)
  • «Описание: » - произвольная текстовая информация

5. Import from R-Keeper 7


5.1. Setup

5.1.1. You have to copy RK7 connection modules from RK7 distributive folder \bin\sh4tr\ and SHTR.DLL to importer application (ImportRK.exe) folder, they are listed below. Take SHTR.DLL from UCS ftp site (find it in /dealers/storehouse/sh4/shtr.dll/RK7/[version] folder) - this SHTR.DLL is for the newest SH4 versions; for old SH4 versions you have to find proper DLL somewhere in your archive (versions before SH4.78 - take this file from old RK7 distributive also), but it is strongly recommended to use newest version of each software.

dllman.dll
errors32.dll
Netkern.dll
rk7tosh4.dll
rk7tosh4.ini
SHTR.DLL
TCPSOC.dll
Thread32.dll

5.1.2. You have to set up importer application settings file rk7tosh4.ini (this file you have to put near ImportRK.exe as usually) as follows:

[REFSERVER7]
ServerName = ENGRK7SRV
ClientName = SH4cliENG
NetworkTimeout = 3600000
RestaurantCode=24
[NETKERN]
PROTOCOLS = tcpsoc.DLL
[TCPSOC]
listen = 0

where:
"ServerName" - Reference/Report server name from rk7srv.ini ;
"ClientName" - Unique Client (importer) name ;
"RestaurantCode" - Your restaurant code from RK7 manager station (remove this string for importing data of all restaurants on that server).
5.1.3. To set up import parameters use IRkSetup.exe utility from \UCS\SH4\ folder (installed with a SH4 client).

5.1.3.1. You have to give any valid empty path in "Path" to store temporary files.

5.1.3.2. If you want to separate expenditure by stocks, enable "break by stocks" property. Do not forget to assign stock-category dependance in "additionally" tab.


5.1.4. If you set RK7 to export Alternative names we recommend that you enable parameter "Alt. name property must be filled" to make sure all Alt.names be filled on each object creation.

5.1.5. Check sale place to be the same as SH4 root menu classification one.

5.2. Go on import

5.2.1. Start ImportRK.exe utility from \UCS\SH4\ folder (installed with a SH4 client).

В приложении ImportRK setup utility (по умолчанию C:\UCS\SH4\IRkSetup.exe) в верхней части экрана указываются используемые товарные группы - по умолчанию их две – Товары и Меню ресторана. Вы можете добавить столько товарных групп, сколько может понадобиться для работы (например, Дополнительные блюда или Блюда Ресторана №2 и т.д.).

Для каждой товарной группы необходимо заполнить следующие параметры:

  • Словари: Путь – указать полный путь к словарям – этот путь может ссылаться на сетевой диск или сетевой ресурс (например \\UNIT99\RK6\DB). В качестве словарей могут быть базы данных R-Keeper (таблицы Paradox) либо DBF-таблицы, сформированные приложением R-Keeper «Транспорт данных» - в зависимости от того, какой вариант используется, необходимо установить правильный
  • Тип источника: - Paradox в случае использования базы данных R-Keeper и Dbase,в случае использования внешних DBF таблиц
  • Расход: все параметры аналогичны предыдущему пункту Словари, за исключением того, что существует дополнительный Тип источника-UDB, который используется в том случае, если в качестве источника для расхода выступает база данных R-Keeper версии выше, чем 6.75. Если используется тип источника UDB, необходимо в файле RKEEPER.INI (должен находиться в той же директории, откуда запускается ImportRK.exe вместе с файлом RKLOGIN.DLL) прописать пути к накопительным базам R-Keeper – параметры Alias1 и Alias2.
  • При импорте расхода блюд с использованием типа источника данных UDB необходимо в системе R-Keeper завести пользователя sklad с паролем sklad

5.3. Automatic import

5.3.1. In RK7 manager station check "Data wait time interval" property value to be set enough to get all data from cash servers (for example, 00:30).
5.3.2. Point a pathway to the batch with import commands (create this file and put to the location set).

5.3.3. You have to set all properties in IRkSetup.exe, Restaurant code and user credentials among them.
5.3.4. Your batch file should contain:
cls
cd C:\ucs\sh4\
ImportRK.exe SDBSERV 136 %1 1
pause

5.3.5. Batch file settings: "C:\ucs\sh4\" is a pathway to ImportRK.exe; "SDBSERV" is a SH4 server name; "136" is an external restaurant code (the same as that you set in IRkSetup.exe); "%1 1" is not changeable.

5.4. Import errors

5.4.1. Follow SH4 errors guide on this site.
5.4.2. Make sure that you use proper version of SHTR.DLL from your SH4 version.
5.4.3. Test import with I_TEST utility described in 3.1. of http://support.ucs.ru/en/node/5532 .


6. Device capabilities


6.1. What device supported

6.1.1. StoreHouse4 is able to work with barcode readers (at least version 4.26.34) in order to input goods names to documents or do a search in a document, also do a document search by its number (independently).
6.1.2. In order to use the third available option from 6.1.1. you have to print not default document layout with barcode number.

6.2. Connection settings

6.2.1. To connect scanner to SH4 you have to setup COMSCN.EXE and SHSetup.exe.
6.2.2. COMCSN utility could be taken from UCS ftp site.
6.2.3. COMSCN.EXE should be placed to the \ucs\sh4\ folder (SH4 main directory).
6.2.4. COMSCN.EXE utility uses COMSCN.INI settings (not exist by default).
6.2.5. Create blank COMSCN.INI file in the SH4 folder mentioned.
6.2.6. COMSCN.INI format:

[Settings]
Port=COM1
BaudRate=9600
ByteSize=8
Parity=0
StopBits=0
6.2.7. Settings description

6.2.7.1. [Settings] is a main section.
6.2.7.2. Port=COM1 is a reader com port name.
6.2.7.3. BaudRate=9600 is a com port speed.
6.2.7.4. ByteSize=8 is a data bits of com port. ByteSize from 4 to 8 values possible.
6.2.7.5. Parity=0 is a parity bits of com port. Possible values: 0 - No Parity, 1 - Odd Parity, 2 - Even Parity, 3 - Mark Parity, 4 - Space Parity.
6.2.7.6. StopBits=0 is a stop bits. Possible values: 0 for 1 Stop Bit), 1 (for 1,5 Stop Bits) or 2 (for 2 Stop Bits).
6.2.8. COMSCN.EXE should be on when using barcode reader (we recommend you setup its autostart).
6.2.9. You have to set the following in SHSetup.exe:
6.2.9.1. "Allow external devices" to make COMSCN.EXE work with.
6.2.9.2. "Get external device data automatically".

6.3. Using barcode reader

Как отмечалось выше, сканер в программе не может использоваться одновременно для ввода товара и для поиска товара в накладной. Текущее поведение сканера определяется опцией в настройках: "Сервис" - "Настройки склада...", далее закладка "Накладные", параметр "Использовать сканер для поиска". При включенном параметре сканер будет использоваться для поиска товара (в открытой активной накладной), при выключенном параметре - для ввода товара в накладную.

Значения баркодов товаров должны быть указаны в карточке товара на закладке "Ед. изм." - более подробно, как работать со сканером, описано в руководстве пользователя StoreHouse v4.

Не зависимо от параметра "Использовать сканер для поиска", сканер может быть использован для поиска накладных - для этого используется окно, вызываемое с помощью меню "Документы" - "Найти документ...". Для поиска достаточно считать штрих-код (в котором содержиться номер накладной) и нажать кнопку "Искать".

Если в настройках утилиты SHSetup.exe не отмечен параметр "Автоматически копировать данные от внешних устройств", то результаты сканирования можно скопировать/считать/очистить с помощью пункта меню "Сервис" - "Внешние устройства...".

Примечание: пункт меню "Сервис" - "Внешние устройства..." доступен только при включенном параметре "Разрешить применение внешних устройств" в настройках SHSetup.exe
 


7. Translation


7.1. Create or get libraries

7.1.1. Prepared files

7.1.1.1. Download prepared translation files from UCS ftp server: ftp://ftpint.ucs.ru/dealers/storehouse/sh4/eng/ .
7.1.1.2. If you cannot find appropriate version or language libraries exist, create them yourself as in 7.1.2.

7.1.2. Create files

7.1.2.1. Download from UCS ftp server files for compilation: ftp://ftpint.ucs.ru/dealers/Foreigns/Translation/SH4/COMPILATION.rar .

7.1.2.1.1. We also provide translation package (Delphi is not included) with English example: ftp://ftp.ucs.ru/Foreigns/SH4_translation/ .

7.1.2.2. Get somewhere latest translated files to English, if you need them when translating from English to your language. ftp://ftpint.ucs.ru/dealers/storehouse/sh4/eng/ENG_RSM/ .

7.1.2.3. Extract archive COMPILATION.rar to your local hard drive.

7.1.2.4. Run program RSM.EXE (Resource maker). This software is additional utility made by UCS.

7.1.2.4.1. Create new project (File -> new project). Or open existing one if you translate from English.

7.1.2.5. Select project language and version for your translation.

7.1.2.6. Select Project -> Add source file and select file SH.exe from folder where shouse is installed. Also add to this project shadm.bpl, shc.exe and shsetup.exe files.

7.1.2.7. When using already created project form FTP, remove existing link before adding your correct link (Project -> Remove source file).

7.1.2.8. Save project (for example, SH4.RSM).

7.1.2.9. For SH4 core you will need to create 5 projects:

7.1.2.9.1. SH4 (already described). For "sh4.rsm" project, source files are: sh.exe; shc.exe; shsetup.exe; ShAdm.bpl.

7.1.2.9.2. SDB_CLIENT (files: doman.dll, sdbcli.dll, dmctrl.bpl, frprn.bpl).  For "SdbCli.rsm" project, source files are: SdbCli.dll; FrPrn.bpl; DmCtrl.bpl; DoMan.dll.

7.1.3.9.3. SDB_SERVER (files: sdbman.exe, sdbsconf.exe),

7.1.3.9.4. RK_IMPORT (file: importrk.exe),

7.1.3.9.5. IMPORT_SETUP (file: IRkSetup.exe).

7.1.2.10. Open tab “Duplicated resources”. If you see any string in this tab – check if you've created correct project (if you added correct files to project, correct quantity of source files).

7.1.2.11. If file set is correct, as defined above, but there are strings in “Duplicated resources” inform UCS office.

7.1.2.12. Open tab “Data”.

7.1.2.12.1. As for BITMAP, specify image filename. This image must be in the same folder.
7.1.2.12.2. Fill in result string in UNICODE.

7.1.2.13. Set source font (Project -> Set source font).

7.1.2.14. Set result font (Settings -> Set font).

7.1.2.15. Translation should be made in column “Result” (If string is not translated it has blue square at beginning, if it has red square – source string was changed from previous version, if green – string was deleted from string).
7.1.2.16. First strings are for loading pictures (bitmaps) to program. Result picture should be 20x20 pixels.

7.1.2.17. After translation is finished save project to rc file (File -> Save resource file).

7.1.2.18. Install Delphi2 or higher. Delphi 7 is fine.

7.1.2.19. Copy to folder, where your rc files are located, files from distributive folder "Compilation".

7.1.2.20. Edit file Translate.bat script. It should have lines for all your projects (RC files).

SET brcc32="C:\Program Files\Borland\Delphi7\Bin\brcc32.exe" -w32
%brcc32% FRA_cli.rc
%brcc32% FRA_imp.rc
%brcc32% FRA_ims.rc
%brcc32% FRA_sh4.rc
%brcc32% FRA_srv.rc
pause

7.1.2.21. Run Translate.bat. Make sure that you didn’t get any error messages during this operation. It should create RES file for your projects.

7.1.2.22. Open (one by one) DPR files with Delphi XX and compile language DLL. To do that - press Ctrl + F9.

7.1.2.22.1. DPR files should have the same filename as RES or RC files.

7.1.2.22.2. Inside DPR file let library name (top line) to be different.

7.1.2.23. If new version came, use existing rsm files, just translate new strings and compile DLL again.

7.2. Set up shlang.exe

7.2.1. Copy folder with translated libraries to some folder (for example: C:\ucs\sh4\).

7.2.2. Run SHlang.exe and set paths for language support dll’s:

7.2.3. Press “Save” and “Exit”.
7.2.4. If you used special font to translate SH4, you need to add new strings to OS registry HKEY_LOCAL_MACHINE\SOFTWARE\UCS\DmLang.

AltFont
SZ
AltFontCharset
SZ
AltFontSize
DWORD

7.2.4.2. These parameters should indicate the font name, charset and size. Iput format you could see in windows registry HKEY_CLASSES_ROOT\MIME\Database.

7.2.4.3. This font substitution method will be necessary if you have got no windows character set for your language (emample: Georgian, Armenian) and use other character set instead.

7.3. Translate other modules

7.3.1. Sh4Utils.exe uses sh4ulang.dll translation method (loading automatically, without assignment in shlang.exe).
7.3.2. sh4ulang.dll library you make like above from Sh4Utils.exe resources with RSM.exe.
7.3.3. you put sh4ulang.dll in the same folder with Sh4Utils.exe and it will work as assigned.

7.4. Apply font usage

7.4.1. You have to set OS additianaly in case you need special font for your language.
7.4.2. Add your font to Windows\Fonts folder.
7.4.3. Set your font in display settings for window(s) area(s).
7.4.4. Set your font in registry using special parameters for [HKEY_LOCAL_MACHINE\SOFTWARE\UCS\DmLang] branch

AltFont (SZ) = Arial Armenian
AltFontCharset (SZ) = windows-1251
AltFontSize (DWORD) = 10

Example values you can find in [HKEY_CLASSES_ROOT\MIME\Database]

 

8. Licensing


8.1. Plug guardant key in SH4 server computer.
8.2. If you have no key drivers already install them before 8.1.
8.3. Run program “SHKey.exe”. It is located in \UCS\SDBCli\.

8.4. Press button “Get primary code” and send gotten code to person who is responsible for licenses at UCS Moscow office with restaurant name and quantity of licenses.
8.5. After you will receive activation code – paste in second field and press “Save answer”. Should appear message “Key successfully activated”. If 7 times will be entered wrong activation code, key will be blocked.


9. Export to other software


9.1. Export to R-Keeper

9.1.1. Get information in manual http://support.ucs.ru/en/node/5865

9.2. Export to 1C accounting

9.2.1. Get information in manual http://support.ucs.ru/en/node/6438

9.3. Export to Capital2008

9.3.1. Capital is the software for reporting and managing financial activity. This program is made outside of UCS.

9.3.2. For export you do need to register OLE module (ex. server) and midas.dll.

9.3.2.1. Sh4Ole.dll you can get from UCS FTP server and put to SH4 folder. Register in OS like (specify full path in):

regsvr32 Sh4Ole.dll
regsvr32 MIDAS.DLL

10. Remarks


10.1. In case you decided to work in restricted negative balance area and set corresponding option in SH4, you may need to receive items.

10.1.1. To make possible to add receiving reports on negative balance in SH4 you have to execute query in SDBMAN:
Procedure: ShEnableNegR0
Library: SHserv.dll