Интеграция с r keeper 7

Введение

Интеграция StoreHouse 5 и r_keeper_7 позволяет синхронизировать базы и вести учет продаж и оставшихся продуктов.

Настройка интеграции

Интеграция r_keeper_7 и StoreHouse 5 работает через утилиту QUSH. После установки StoreHouse, на компьютере появляется служба сервера QUSH, который работает на порту 8087.

Для интеграции баз StoreHouse_5 и r_keeper_7 откройте утилиту Qush_Manager. По умолчанию пользователь - Admin. Пароля нет.

Зайдите в меню Файл > Связки с R_keeper

Нажмите правой кнопкой мыши в левом поле и выберите Создать.

Далее вы увидите окно для связки StoreHouse 5 и данных вашей базы SQL. 

Если r_keeper и StoreHouse 5, стоят на одном компьютере, то в первую строчку необходимо вписать ваш локальный IP, если на разных — IP соответствующих компьютеров. В поле порт tcp/ip — укажите порт вашего сервера SH5, по умолчанию это 7771.

В поля База данных, Пользователь, Пароль впишите данные пользователя вашей базы данных SQL. Далее нажмите кнопки Проверить, чтобы убедится что вы подключились к обеим БД. Нажмите кнопку Сохранить.
Перейдите во вкладку Рестораны, нажмите кнопку Обновить. После обновления вам будут доступны списки ваших ресторанов из базы r_keeper.

Вы можете выбрать либо все рестораны, либо рестораны объединенные одной франшизой или концепцией, либо просто выделив нужные, перед этим выбрав пункт Только выбранные.

Нажмите кнопку Сохранить и перейдите во вкладку Места реализации

В этой вкладке можно выбрать либо все места реализации, либо отдельные, например, бар. Места реализации и их настройки вы можете посмотреть в менеджерской станции R-Keeper 7.

Нажмите кнопку Сохранить и перейдите во вкладку Корреспонденты. Здесь вы можете выбрать, как хотите проводить выгрузку:

Нажмите Сохранить и перейдите во вкладку Справочники.

Выберите группы меню ресторана, если их не существует вы можете создать новые прямо в QUSH. Для этого нажмите на квадратную кнопку с многоточием. 

Перед вами появится окно Создать группу. Дайте ей имя, дайте имя группе модификаторов. Нажмите кнопку ОК.
По желанию, можно определить по какой категории товаров делать выгрузку. Стандартный набор категорий ниже:

  1. Не задано — значение по умолчанию.
  2. Сервис-печать — разделения заказов по принтерам для поваров.
  3. Классификация — разделения заказов на группы (холодное, горячее и пр)
  4. Рейтинги кассиров — разделение заказов согласно рейтингу сумм на сотрудника
  5. Группы для KPI-аналитик — разделение заказов согласно группам для KPI-аналитик. Группы заводятся вручную.

Все категории товаров можно создать и посмотреть в менеджерской станции r_keeper.

Далее вы можете выбрать, как фильтровать справочники:

Далее вы можете галочками обозначить, выгружать ли блюда без цены, выгружать ли предоплаты в заявки и рассчитывать ли налоги по настройкам r_keeper или расчитывать налоги по настройкам StoreHouse 5.
Далее вам нужно определить будет ли учитываться НДС и НСП, заданные в менеджерской станции r_keeper.

Нажмите Сохранить и перейдите во вкладку Автозапуск. Здесь можно задать критерии и время автоматического импорта данных из r_keeper.

Здесь вы можете задать время запуска, определить за какой период делать импорт, а также разрешить автоматическое и онлайн списание.

Если поставить галочку напротив пункта Уведомлять об ошибках по e-mail, то вы будете получать уведомления при ошибке импорта.

Нажмите Сохранить и перейдите во вкладку «Уведомления».

Во вкладке Уведомления можно настроить отправку уведомлений на почтовый ящик. В левом окне необходимо ввести параметры почтового ящика, с которого будет производиться рассылка. Справа вводятся список получателей рассылки.

Нажмите кнопку Проверить, что отправить тестовое письмо на почтовый ящик. После этого нажмите Сохранить.

Настройка автоматического списания

При импорте продаж из r_keeper_7 может быть настроено автоматическое списание.

Автоматическое списание – автоматическое формирование системой накладных на основе импортированной заявки по заранее заданным правилам. Т.е. нажав кнопку Запустить вручную или по расписанию будет не только загружена заявка, но и сразу сформированы необходимые накладные, для ее обработки.

Если комплекты выверены и необходимое количество товаров оприходовано на подразделения списания, то формирование накладных произойдет без ошибок. Также при отсутствии необходимого количества товаров на остатках подразделений списания накладные будут созданы с компенсированными записями, которые можно проанализировать и исправить в любой момент.

Если же в расходе r_keeper были новые блюда, по которым не определены подразделения списания, не созданы комплекты либо комплекты созданы с ошибками, то система не сможет обработать заявки в полном объеме. В результате чего будет сформирован протокол ошибок. Данный протокол можно просмотреть в протоколе импорта, если импорт запускался вручную.

Если импорт запускается автоматически системой, то в случае возникновения ошибок при импорте или списании, можно настроить уведомление по электронной почте При соответствующих настройках сервер импорта будет импортировать данные из r_keeper_ автоматически. Для этого на закладке Автозапуск необходимо указать настройки.

 

Запускать импорт ежедневно – после выставления этого флага импорт данных из R-Keeper 7 будет запускаться автоматически каждый день в указанное время.
Время запуска– в это поле с помощью клавиатуры внесите время начала автоматического импорта.
Продажи за… – в этом поле необходимо выбрать день, за который будут автоматически выгружаться продажи: Сегодня, Вчера или Позавчера.

Автоматическое списание – при выставлении данного флага после операции Импорт из RK система будет пытаться произвести списание по импортированным заявкам, т.е. создать накладные на основе импортированных заявок.
Уведомлять об ошибках по e-mail – если выставлен флаг Запускать импорт ежедневно»\, то при выставлении данного флага и настройках Уведомлений при возникновении ошибок импорта или автоматического списания, информация будет отправлена на e-mail-ы, указанные в настройках Уведомлений.
Следующий запуск: дата и время – в данном поле будет выведена информация о следующем автоматическом запуске импорта, если вставлен флаг Запускать импорт ежедневно

В списке заявок не могут быть созданы две импортированных заявки, у которых дата, место реализации, подразделение, заказчик одинаковые. Поэтому если документы необходимо импортировать заново, то предварительно удалите уже созданные импортом заявки за требуемый период.

Проверка работы

Теперь когда настройка проведена, перейдите в раздел «Задания». Здесь вы можете провести импорт данных в ручном режиме.

Выберите необходимый период и нажмите кнопку «Запустить».
Если вы всё настроили верно, то увидите в графе результат Успешно:

Если при импорте были ошибки, то история импорта будет выглядеть так:

Чтобы подробнее узнать о результатах импорта или ошибках, вы можете нажать 2 раза на нужную строчку и увидеть подробную информацию об импорте:

Если было настроено Автоматическое списание, то в протоколы будет выведена и информация по ошибкам списания.

Список ошибок списания в протоколе будут аналогичен списку ошибок в Предполагаемом расходе, формируемом при ручной обработке импортированных заявок.
Протокол при необходимости можно сохранить в форматах HTML и XML. Для этого откройте протокол, выберите пункт главного меню Задание и выберите пункт с соответствующим форматом.

 

 

 

 

В открывшемся окне выберите место сохранения файла. Также можете изменить имя сохраняемого файла. И нажмите кнопку Сохранить.

Решение проблем

Проблема. Продажи из r_keeper_7 не загружаются в StoreHouse 5 
Причина. Продажи не попали в базу SQL. Зайдите в SQL и посмотрите таблицы ORDERS (заказы), PAYMENTS (оплаты), VISITS (визиты) — в них должны быть данные.
Решение. Проверьте настройки SQL, верно ли указана БД. Если всё верно, перезакачайте смены.

Настройка импорта себестоимостей

Введение

Из StoreHouse 5 можно импортировать себестоимость товаров в r_keeper_7. Если требуется настройка для StoreHouse 4, то она находится здесь.

Копирование библиотек

Для настройки импорта себестоимостей необходимо скопировать файлы DLL из папки StoreHouse, а затем сделать настройки в менеджерской станции. Не забудьте настроить себестомости в StoreHouse, чтобы было что импортировать. 

  1. Скопируйте из папки \StoreHouse_5\Client\ файлы:
    • sDbCli.dll
    • msdset.dll
    • RTL60.BPL
    • domm.dll
  2. В папку менеджерской станции. Обычно это \Rk7Manager или \bin\win
    • Скачайте актуальную библиотеку sh5rki.dll с FTP-сервера. Находится она по адресу ftp://ftp.ucs.ru/StoreHouse 5/_utils/sh5rki/ и распакуйте архив с заменой в папку сервера справочников
    • Скопируйте файл sh5rki.dll в папку менеджерской станции

Настройка в менеджерской станции

  1. Запустите менеджерскую станцию
  2. Создайте новую связку для базы данных StoreHouse в разделе Сервис > Экспорт данных > Конфигурации баз данных SH4
  3. В настройках укажите:
    1. Имя пользователя, например Admin
    2. Сервер:порт для подключения к StoreHouse. В отличии от SH4, здесь не нужно указывать полную строчку подключения, достаточно сервер:порт.
    3. Пароль пользователя
    4. Версию StoreHouse в выпадающем меню
  4. Создайте новую себестоимость в Меню > Тип себестоимостей
    1. Укажите название себестоимости
    2. В настройках поставьте галочки напротив:
      • Использовать в отчетах
      • Разрешить переопределения
    3. В поле настройки StoreHouse выберите ту настройку, которую до этого создавали в Конфигурации баз данных.
    4. По желанию, здесь можно указать Товарную группу — в кавычках, точно как в StoreHouse. Это необязательная настройка, её можно указывать непосредственно перед импортом. Можно перечислить несколько товарных групп через пробел или запятую.
  5. Поставьте статус Активный
  6. Сохраните настройки.

Запуск импорта

Импорт можно запускать 2-мя способами. Непосредственно из меню и через импорт данных. 

  1. В менеджерской станции перейдите в Сервис > Импорт данных > Импорт себестоимостей из StoreHouse
  2. Выберите Тип себестоимости, который вы создали в пункте 4
  3. Выберите Элементы справочника
  4. Выберите Ключ подразделения в выпадающем меню
  5. Если нужно указать товарную группу, укажите её руками в кавычках, точно как в StoreHouse. Можно перечислить несколько товарных групп через пробел или запятую. Например, "Меню ресторана".
  6. По желанию выберите Дату, Тип элемента, Элементы справочника и Метод вычисления
  7. Нажмите ОК
  8. Нажмите ОК.

Чтобы быстро импортировать только нужную группу меню, импорт можно запускать непосредственно из меню. Для этого:

  1. В менеджерской станции перейдите в Меню > Меню
  2. Нажмите правой кнопкой мыши на нужную группу меню
  3. Выберите Действия > Импорт себестоимости из StoreHouse
  4. Настройте детали импорта, как описано выше и запустите.

Решение проблем

Проблема. Импорт не запускается. Выдаёт ошибку "Библиотека sh5rki.dll не найдена. Импорт из StoreHouse 5 недоступен"

Причина. В папке менеджерской станции не хватает нужных библиотек.
Решение. проверьте наличие всех нужных файлов в менеджерской станции и добавьте по необходимости

  • sh5rki.dll
  • sDbCli.dll
  • msdset.dll
  • RTL60.BPL
  • domm.dll

Перезапустите сервер справочников и менеджерскую станцию. Проверьте ещё раз. 

Проблема. Импорт не запускается. Выдаёт ошибку Error import costs (dll: sdbcli.dll, error: [-2147482645] Ошибка процедуры библиотеки сервера 1003. Поняли, что ошибка возни

Причина. Предприятие — это ресторан в r_keeper_7. Группы меню ресторана привязаны к предприятию. Соответственно, при импорте необходимо выбирать подразделение,  привязанное к правильному предприятию.
Решение. Привяжите подразделения к правильному предприятию.

Настройка онлайн остатков

Введение

Отчёт Онлайн остатки позволяет формировать количественные остатки товаров с учетом текущих продаж R-Keeper V7. Данные о продажах R-Keeper 7 берутся базы данных SQL, которую нужно настроить заранее.

Для формирования корректных остатков необходимо:

  • Настроить связь R-Keeper 7 с MSSQL
  • Настроить Предприятия в Store House 5
  • Ввести все входящие, исходящие и внутренние накладные должны в SH5.
  • Обработать все продажи за прошедший период.

Схема работы отчёта

v Из фильтра отчета «Онлайн остатки» происходит отбор списка «Предприятий» для формирования отчета;

v Из свойств «Предприятий» определяются QushSvc, которые будут обращаться к SQL базам R-Keeper V7;

v Из настроек связок определяется пара «База Sh5 + SQL база RK7»;

v Из SQL базы R-Keeper V7 отбираются продажи за текущую компьютерную дату. 

           ♦  Продажа R-Keeper V7 – закрытые (оплаченные) заказы с учетом возвратов.

v По продажам блюд R-Keeper V7 определяется список израсходованных ингредиентов;

v Из текущих остатков Store House V5 (по каждому подразделению) вычитаются «текущие продажи по ингредиентам» (по каждому подразделению);

v Формируются «Онлайн остатки».

Необходимые настройки системы

Запись текущих продаж R-Keeper в накопительную базу (ы) SQL R-Keeper.

                  ♦  Данные настройки выполняют сотрудники компании UCS или представители компании в регионах.

·       Настройки связок для импорта справочников и продаж в QushMan.exe.

                 ♦ Данные настройки выполняют сотрудники компании UCS или представители компании в регионах.

·       Для справочника «Предприятия» для каждого предприятия должны быть заполнены параметры подключения к QushSvc.exe в атрибуте «Qush IP-адрес:порт» (см. Рис.940) 

Атрибут «Qush IP-адрес:порт» будет создан автоматически при создании чистой базы Store House V5 с версии 5.24.118.

Если база Store House была создана более ранней версией Store House V5, то атрибут необходимо добавить вручную.

v  Запустите приложение SDBMan.exe (см. п.п. 12);

v  Выберите пункт «Обслуживание» - «Статистика»;

v  В открывшемся окне выберите в левой части окна пункт «Поля бинарных объектов» - «aDivisions_AttrsEx»;

v  В правой нижней части окна, используя пункт контекстного меню «Добавить атрибут», создайте новый атрибут.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

v Атрибут должен иметь следующие значения:

  • Идентификатор - $Qush
  • Наименование - Qush IP-адрес:порт
  • Тип данных – tStrP

v  После создания атрибута можно будет заполнить его в справочнике «Предприятия».

Фильтры отчёта

Фильтр отчета «Онлайн остатки» представлен на рисунке ниже.

 

 

 

 

 

 

 

 

 

 

Отчет формируется на текущий момент, поэтому в фильтре нет возможности определить дату.

Подразделения – в фильтре отчета можно определить подразделения, по которым будут выводиться остатки. Для выбора подразделений кликните мышкой в этом поле, в правом конце поля появится кнопка  . При клике по этой кнопке открывается окно, в котором можно выбрать из списка подразделений интересующие, установив флаг в строке с нужным подразделением (см. Рис. 943).

 

 

 

 

 

 

 

 

               ♦  Если у пользователя ограничены фильтры подразделений для отчетов по «группе подразделений» (см. п.п. 12.2.2.3.4), то в список для фильтрации подразделений будут выведены только доступные этому пользователю подразделения.

Юр. лица – если онлайн остатки надо отобразить только для определенных собственных юридических лиц, выберите их из списка в открывающемся окне из этого поля, аналогично выбору Подразделения в предыдущем поле.

               ♦  Если у пользователя ограничены фильтры подразделений для отчетов по «группе подразделений» (см. п.п. 12.2.2.3.4), то в список для фильтрации юр. лиц будут выведены только доступные этому пользователю юр. лица. Определение доступности происходит относительно подразделений.

Предприятия – в этом поле можно определить предприятия, по подразделениям которых будут отображены онлайн остатки.

               ♦  Если у пользователя ограничены фильтры подразделений для отчетов по «группе подразделений» (см. п.п. 12.2.2.3.4), то в список для фильтрации предприятий будут выведены только доступные этому пользователю предприятия. Определение доступности происходит относительно подразделений.

Объединять данные – в этом поле можно задать способ объединения товаров в онлайн ведомости остатков. Возможные значения: не группировать, по подразделениям, по юр. лицам, по предприятиям.

Товарные группы – в этом поле можно выбрать из дерева товарных групп интересующую Вас группу. Если Вы выбрали группу, содержащую подгруппы, онлайн ведомость остатков будет строиться, включая вложенные в указанную товарную группу подгруппы.

Группировать – в этом поле можно задать способ группировки онлайн остатков. Возможные значения: не группировать, по товарным группам.

Использовать базовую ед. изм. – по умолчанию все отчеты, в которых фигурируют товары, формируются в единицах измерения «для отчетов» (см. п.п. 7.1.6.4.1). Отчет «Онлайн остатки» можно сформировать в «базовой» единице измерения. Для этого выставьте соответствующий флаг в фильтре.

После заполнения фильтра, для вывода «Онлайн остатков», нажмите кнопку [Применить].

В этот момент произойдет обращение в R-Keeper для получения продаж. 

Область отчета содержит перечень товаров, из заданной в фильтре товарной группы с рассчитанным остатком на текущий момент с учетом продаж R-Keeper.

В фильтре можно задать дополнительные группировки отчета.

  • Код – содержит номенклатурный номер товара Store House.
  • Товар – содержит наименование товара. В отчет не выводится расход блюд R-Keeper. Только товары Store House, остатки которых учитываются на предприятии. 
  • Ед. изм. – единица измерения товара для формирования отчетов или базовая единица измерения, если в фильтре отчета был выставлен соответствующий флаг
  • Количество – количественный остаток товара, рассчитанный на «сейчас» с учетом продаж R-Keeper. Отрицательное значение в поле Количество означает, что на момент формирования отчета Онлайн остатки данного товара не хватало на остатках в системе, для обработки расхода R-Keeper. И если сформировать документы списания по данному расходу, то будут сформированы компенсированные записи для «отрицательных» товаров.

Пример отчёта

Отчет Онлайн остатки представлен ниже.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Окно отчёта разбито на две части:

  • Верхняя часть содержит информацию о количественных остатках.
  • Нижняя часть содержит перечень ошибок, которые не позволили обработать расход из R-Keeper V7 в полном объеме.

Если в нижней части отчета есть записи с ошибками, то сформированный отчет нельзя считать полностью достоверным. Необходимо исправить все ошибки. Описание столбцов ниже:

  • Сервер – IP и порт подключения к QushSvc.exe, указанные при настройке в свойствах предприятия;
  • Связка – наименование связки из QushSvc.exe, по которой происходит подключение к базе R-Keeper V7;
  • Сообщение – текст ошибки.

Возможные ошибки 

  • Connection refused – не запущен QushSvc.exe, указанный в настройках предприятия;
  • Для товара не определено подразделение списания (наименование товара) – в расходе блюд R-Keeper есть блюдо, для которого в Store House не определено подразделение списания для места реализации на карточке товара. Определите подразделение списания и обновите отчет.
  • Не найден товар по GUID – в расходе блюд R-Keeper есть блюдо, которое еще не импортировалось в Store House (новое блюдо). Необходимо произвести импорт товаров для обновления справочников в Store House. Нужно также создать комплект, если блюдо требует приготовления.
  • Не найден по GUID модификатор для товара (наименование товара, для которого в расходе блюд R-Keeper фигурирует проблемный модификатор) – в расходе блюд R-Keeper есть модификатор, который еще не импортировался в Store House (новый модификатор). Необходимо произвести импорт товаров из RK7 для обновления справочников Store House. Нужно создать комплект, если модификатор требует приготовления.
    Если для товара из расхода блюд R-Keeper не определен комплект, комплект пустой, или пустой комплект для полуфабриката, сообщений об ошибке не будет в протоколе отчета.

Импорт себестоимости в r keeper 7 через Feature Server

Введение

Из StoreHouse 5 в r_keeper_7 можно импортировать себестоимость и другие данные в режиме онлайн. Для этого необходим Feature Server, идущий в комплекте с интерактивными отчетами. Соответственно, перед настройкой импорта, у вас должно быть установлены и запущены:

i_Guid={D54BA83D-EA0F-4ADC-834D-70C336259F6D}
instance_name=171848
MasterServer=1

Обратите внимание, что импортированная таким образом себестоимость не будет отображаться у блюд — только в отчетах.

Обновление Feature Server

Если у вас установлена старая версия плагина интерактивных отчетов и Feature Server, их лучше обновить. В ранних версиях FS есть требование о необходимости установки FS и SQL на одном компьютере, но с версии 1.36 это не актуально.

Для обновления Feature Server и плагина:

  1. Скачайте последнюю версию с FTP-сервера ftp://ftp.ucs.ru/rk7/other/IR_reports/
  2. Распакуйте архив в удобное место. Скопируйте с заменой все файлы в папку установленного FS. Файла настроек в архиве нет, поэтому существующие настройки не потеряются. 
  3. Закройте менеджерскую станцию и скопируйте содержимое архива из папки plugins в одноименную папку менеджерской станции
  4. Запустите FS и менеджерскую станцию.

Настройки в менеджерской станции

Для работы импорта необходима настроенная связь с MS SQL и интерактивных отчётов и установленный сервер WebAPI 2, подключенный к StoreHouse 5.

  1. Перейдите в меню Расширения > База данных.
    1. Если видите ошибку Недопустимое имя объекта PLG_OBJECTS
    2. Откройте обозреватель MS SQL и выполните скрипт:
    3. CREATE VIEW [dbo].[PLG_OBJECTS] AS
      SELECT
      GUIDSTRING
      ,CODE
      ,NAME
      ,ALTNAME
      ,STATUS
      FROM dbo.RESTAURANTS
      WHERE (STATUS = 3)
    4. Ошибка должна исчезнуть.
  2. Нажмите правой кнопкой мыши на раздел Все и выберите пункт Создать новую группу баз данных. Переименуйте её по желанию.
  3. Подобным образом нажмите на группу и создайте новую базу данных
  4. Находясь в меню группы, выберите базу данных в правом меню и заполните поля:
    1. Название
    2. В разделе Основное укажите данные для подключения к серверу WebAPI 2:
      1. Имя пользователя StoreHouse
      2. Пароль пользователя StoreHouse. Важно! У пользователя StoreHouse обязательно должен быть пароль.
      3. Данные сетевого подключения к WebAPI, в формате IP:PORT, например: localhost:9999
    3. В разделе Другое:
      1. ​Поставьте галочки напротив SH5
      2. Заполните поля Параметр Начальная дата и Параметр Конечная дата
    4. В разделе Настройки импорта StoreHouse
      1. ​В полях Валюта и Группа товаров укажите параметры для импорта данных.
        Примечание: валюта и группа товаров доступны для выбора только при удачном подключении к серверу StoreHouse
      2. Поле Место реализации заполнять не нужно
      3. Если в StoreHouse производится спец учет, поставьте галочки в зоне полях Специальный учет и Рассчитывать в ед. изм. "для расхода"
    5. Нажмите сохранить 
  5. Подключение настроено, теперь его необходимо проверить. Нажмите правой кнопкой мыши на базу данных в меню слева и выберите пункт Проверка соединения с БД...
    • Если подключение настроено верно, появится сообщение:
    • Если соединение настроено неверно, то появится сообщение:
  6. Теперь необходимо привязать объект к созданной базе данных в списке слева. Для этого нажмите правой кнопкой мыши на поле справа и выберите пункт Добавить новый объект

    Нажмите Добавить и сохраните изменения.
  7. Откройте StoreHouse 5 и убедитесь, что в контрагентах есть хотя бы 1 подразделение. Если его нет — создайте. 
    Делается это в меню Словари > Контрагенты > Подразделения.

    Если предприятия нет — создайте.
  8. Перейдите в Меню > Классификации блюд и скопируйте GUID классификации, которую планируете использовать. В классификации обязательно должны быть вложенные категории.

    1. Остановите Feature Server и откройте его файл настроек — IRReportsFSPrj.ini
    2. Добавьте в блок [FS_ADDITIONAL] строчку:
    3. SH4_Class={B07330CD-D17E-4151-AC2F-DE341C163C7D}
    4. Где после знака "=" вставьте скопированный GUID классификации. Если секция [FS_ADDITIONAL] отсутствует, добавьте.
    5. Сохраните файл и запустите Feature Server
  9. Перейдите в меню Настройки > Центральный офис > Рестораны, и нажмите правой кнопкой мыши на ресторане, который необходимо связать со StoreHouse. Выберите пункт Действия > Редактор связи со складом
  10. Выберите необходимые категории. В поле Store House 4 их свойств укажитие подразделение, с которого будет производиться выгрузка.
    Не обращайте внимания на название поля, всё будет работать нормально.
     
  11. Если классификации появились, но выбор подразделения пустой, то  проверьте:
    • Есть ли в базе StoreHouse 5 подразделения? Они должны быть, хотя бы 1
    • Если подразделения в StoreHouse есть, то в базе данных SQL имя_базы_STAT_SH4_SHIFTS_FOODCOST в таблице dbo.STAT_SH4_SHIFTS_CORR должен быть их список. Поле TYPECORR у подразделения должно быть равно 0
    • Если в SQL нет записей с TYPECORR=0, то очистите папку с логами Feature Server, измените имя подключения к базе StoreHouse и нажмите кнопку сохранить. Таким образом, FS должен повторно запросить данные у StoreHouse 5.
  12. Сохраните и закройте менеджерскую станцию.
  13. ​В конфигурационный файл плагина интерактивных отчётов RK7MAN\plugins\SchRepPluginClient\SchRepPluginClient.ini добавьте текст в конец файла:
    • [PLG_ACC]
      use_accounts = 1
      [PLG_PLAN]
      use_plan_params = 1
      [PLG_SH]
      use_sh_params = 1
  14. Сохраните и запустите менеджерскую станцию.

Запуск импорта

Запустите серверы:

  • UCS Common
  • Feature 
  • WebAPI 2
  • StoreHouse 5

И откройте менеджерскую станцию.

Если все настройки правильные, Feature Server начнёт загружать данные из StoreHouse 5 в r_keeper_7 за выбранный период:

Если в логе Feature Server есть строчки Date... Invoice load, значит всё работет правильно.

Пересчитать данные StoreHouse можно зайдя в Интерактивные Отчеты (ИО) > Отчеты по безопасности > Системные операции  и нажав кнопку Пересчитать данные SH.